[SciPy-user] matplotlib, numpy and scipy

Robert Kern robert.kern at gmail.com
Sun Oct 1 15:30:38 CDT 2006


Seweryn Kokot wrote:
> As I remember some time ago matplotlib required scipy and now requires
> numpy. Any explaination?

numpy used to be called "scipy core" and was renamed because people got confused 
and thought that implied they had to install all of scipy.

> I read somewhere that scipy may conflict with numpy... is it true?

No, scipy builds on top of numpy.

-- 
Robert Kern

"I have come to believe that the whole world is an enigma, a harmless enigma
  that is made terrible by our own mad attempt to interpret it as though it had
  an underlying truth."
   -- Umberto Eco


More information about the SciPy-user mailing list