[SciPy-user] matplotlib on osx

Rob Hetland hetland at tamu.edu
Tue Oct 3 08:56:12 CDT 2006


I also got mpl to work using the i-Installer to install Freetype2 and  
libpng (they are both available as universal binaries).

I have installed on my macbook pro and a number of student macbooks  
with no issues using this method,

-Rob

On Oct 2, 2006, at 8:40 AM, Steve Lianoglou wrote:

> Hi John,
>
>> Has anyone gotten matplotlib running on OSX recently? I tried
>> upgrading to 10.4.8, and building Python 2.5, numpy, scipy, libpng,
>> and freetype from source. Everything went fine, even matplotlib
>> installed without an error. But when I import matplotlib I get
>
> Mine seems to be working well.
>
> I've installed python and the various dependencies of matplotplib via
> MacPorts.
>
> The dependencies for py-matplotlib are:
> python24, freetype, libpng, antigraingeometry, py-numarray, py-
> numeric, py-dateutil, py-tz
>
> I then reinstalled matplotlib myself via recent svn checkouts since I
> wanted it to be working with the latest svn numpy as well. So I have
> some extra stuff lying around since the ports installations depend on
> them, but it all seems to work fine for me.
>
> If you want to use python 2.5, however, MacPorts won't do you any  
> good.
>
> HTH,
> -steve
>
>
> _______________________________________________
> SciPy-user mailing list
> SciPy-user at scipy.org
> http://projects.scipy.org/mailman/listinfo/scipy-user

----
Rob Hetland, Associate Professor
Dept. of Oceanography, Texas A&M University
http://pong.tamu.edu/~rob
phone: 979-458-0096, fax: 979-845-6331




More information about the SciPy-user mailing list