[SciPy-user] SuSE 10.1 installation problem

Marian Jakubik mjakubik at ta3.sk
Thu Oct 5 04:20:59 CDT 2006


Hi everyone,

I'm a SciPy newbie and have problem with installing it on SuSE 10.1.

I installed numpy-1.0rc1, then blas-3.0-926.i586.rpm &
lapack-3.0-926.i586.rpm and then scipy-0.5.1...

I tried to run this very simple script:
...
from scipy import *
p = poly1d([3,4,5])
print p
...

and I've got this error:

Traceback (most recent call last):
  File "1.py", line 1, in ?
    from scipy import *
  File
"/usr/local/lib/python2.4/site-packages/scipy/signal/__init__.py", line
9, in ? from bsplines import * File
"/usr/local/lib/python2.4/site-packages/scipy/signal/bsplines.py", line
3, in ? import scipy.special File
"/usr/local/lib/python2.4/site-packages/scipy/special/__init__.py",
line 10, in ? import orthogonal File
"/usr/local/lib/python2.4/site-packages/scipy/special/orthogonal.py",
line 67, in ? from scipy.linalg import eig File
"/usr/local/lib/python2.4/site-packages/scipy/linalg/__init__.py", line
8, in ? from basic import * File
"/usr/local/lib/python2.4/site-packages/scipy/linalg/basic.py", line
17, in ? from lapack import get_lapack_funcs File
"/usr/local/lib/python2.4/site-packages/scipy/linalg/lapack.py", line
17, in ? from scipy.linalg import flapack
ImportError: /usr/lib/libblas.so.3: undefined symbol: _gfortran_filename

I think the problem is in "from scipy import *" statement and is linked to blas & lapack...

Can anyone help me, pls?


Best regards,
Marian Jakubik


More information about the SciPy-user mailing list