[SciPy-user] Problem installing scipy-0.5.1 on FC5

Andrew B. Young andrew.young at sri.com
Mon Oct 9 16:11:06 CDT 2006


That did it!
Thanks Travis.

Travis Oliphant wrote:
> Andrew B. Young wrote:
>   
>> I would like to use splrep() splev() for matplotlib plot smoothing 
>> similar to gnuplot smoothing 
>> (http://mail.python.org/pipermail/python-list/2005-April/275568.html) 
>> but the install fails.  I followed the instructions for FC5 on 
>> http://www.scipy.org/Installing_SciPy/Linux?highlight=%28%28----%28-%2A%29%28%5Cr%29%3F%5Cn%29%28.%2A%29CategoryInstallation%5Cb%29
>>
>> sudo yum install numpy
>>   Installed: numpy.i386 0:0.9.8-1.fc5
>>   Dependency Installed: atlas.i386 0:3.6.0-10.fc5
>> sudo yum install lapack-devel blas-devel
>>   Installed: blas-devel.i386 0:3.0-37.fc5 lapack-devel.i386 0:3.0-37.fc5
>>   Dependency Installed: blas.i386 0:3.0-37.fc5 lapack.i386 0:3.0-37.fc5
>>
>> Downloaded scipy-0.5.1
>> cd /usr/src/scipy-0.5.1
>> python setup.py install, and...
>>     File 
>> "/usr/lib/python2.4/site-packages/numpy/distutils/misc_util.py", line 
>> 655, in _get_configuration_from_setup_py
>>     ('.py', 'U', 1))
>>   File "Lib/ndimage/setup.py", line 3, in ?
>>     from numpy.numarray import get_numarray_include_dirs
>>
>>   
>>     
> The dependencies are wrong.  SciPy 0.5.1 requires numpy 1.0  not 
> numpy-0.9.8.
>
> The required numarray compatibility layer is in numpy 1.0 not in 
> numarray.  You don't need to install numarray at all.
>
> Install numpy 1.0
>
> -Travis
>
> _______________________________________________
> SciPy-user mailing list
> SciPy-user at scipy.org
> http://projects.scipy.org/mailman/listinfo/scipy-user
>   



More information about the SciPy-user mailing list