[SciPy-user] Missing library will not allow SciPy to load.

Tom Bridgman cygnusx1 at mac.com
Tue Oct 10 21:21:28 CDT 2006


> When I do
>
> from scipy import *
>
> I get the following error:
>
> ImportError: Failure linking new module:
> /Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/ 
> site-packages/scipy/sparse/sparsetools.so:
> Library not loaded: /usr/local/lib/libg2c.0.dylib
>   Referenced from:
> /Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/ 
> site-packages/scipy/sparse/sparsetools.so
>   Reason: image not found
>
>
> It seems I'm missing  libg2c.0.dylib.  I just installed the SciPy
> SuperPack.  I guess it wasn't in there or was supposed to be installed
> from some other package.  Does anyone know about this?
>
I believe this is installed as part of the g77 package (g77v3.4- 
bin.tar.gz).

Tom
--
W.T. Bridgman, Ph.D.
Physics & Astronomy



More information about the SciPy-user mailing list