[SciPy-user] Installation Problems on Mac OS 10.4

David M. Cooke cookedm at physics.mcmaster.ca
Tue Oct 24 13:46:16 CDT 2006


On Oct 21, 2006, at 12:48 , R. Padraic Springuel wrote:

> Okay, I finally figured out the problem with the Fortran compiler, and
> was able to get Scipy to find and use gfortran on my system.  However,
> I'm now getting the following error:
>
> gcc: unrecognized option '-no-cpp-precomp'
> cc1: error: unrecognized command line option "-mno-fused-madd"
> cc1: error: unrecognized command line option "-arch"
> cc1: error: unrecognized command line option "-arch"
> cc1: error: unrecognized command line option "-Wno-long-double"
> gcc: unrecognized option '-no-cpp-precomp'
> cc1: error: unrecognized command line option "-mno-fused-madd"
> cc1: error: unrecognized command line option "-arch"
> cc1: error: unrecognized command line option "-arch"
> cc1: error: unrecognized command line option "-Wno-long-double"
> error: Command "gcc -arch ppc -arch i386 -isysroot
> /Developer/SDKs/MacOSX10.4u.sdk -fno-strict-aliasing -Wno-long-double
> -no-cpp-precomp -mno-fused-madd -fno-common -dynamic -DNDEBUG -g -O3
> -DUSE_VENDOR_BLAS=1 -c Lib/linsolve/SuperLU/SRC/clangs.c -o
> build/temp.macosx-10.3-fat-2.5/Lib/linsolve/SuperLU/SRC/clangs.o"  
> failed
> with exit status 1
>
> I get this error with both gcc 4.0 and 3.3.  Does anyone know how  
> to fix it?

Are you sure you're using Apple's gcc? These look the errors that a  
non-Apple gcc would spew (especially the -arch and -no-cpp-precomp).  
Check what gcc --version gives you. You can also specify which one to  
use by setting the environment variable CC (as in, 'export CC=/usr/ 
bin/gcc-4.0').

-- 
|>|\/|<
/------------------------------------------------------------------\
|David M. Cooke              http://arbutus.physics.mcmaster.ca/dmc/
|cookedm at physics.mcmaster.ca



More information about the SciPy-user mailing list