[SciPy-user] Interpolate 1D

Maik Trömel maik.troemel at maitro.net
Tue Sep 5 07:05:38 CDT 2006


Hello list,

when I try to use scipy.interpolate.interpolate.interp1d( olddims[-1], 
a, kind='cubic' ) I get an ERROR:
 
File 
"/usr/lib/python2.3/site-packages/scipy/interpolate/interpolate.py", 
line 118, in __init__
    raise NotImplementedError, "Only linear supported for now. Use "\
NotImplementedError: Only linear supported for now. Use fitpack routines 
for other types.

But under 
http://www.scipy.org/doc/api_docs/scipy.interpolate.interpolate.interp1d.html 
kind = 'cubic' is listed. Whats wrong with the command? Or is cubic not 
implemented yet?

Thanks for your help!

Greetings Maik



More information about the SciPy-user mailing list