[SciPy-user] Trouble installing on OSX 10.4 Intel

David Andrews irbdavid at gmail.com
Thu Sep 14 16:18:20 CDT 2006


Hi John,

I'm looking at the contents of the installer archive, i don't seem to
see an __init_.py in the matplotlib directory, though they do appear
for sub directories of the matplotlib directory (numericx/ etc) -
perhaps its physically missing from the installer?

Conor; as John has noted the lack of an __init__.py in the module
would render it invisible to python, causing the problem we're seein

Cheers,

DAve

On 14/09/06, John Hassler <hasslerjc at adelphia.net> wrote:
> I got the "No module named matplotlib.pylab" error.  I'd installed from
> the windows installer, and after some considerable head-scratching,
> figured out that the __init__.py file was missing from the matplotlib
> module ... so Python didn't recognize it as a module.  I found the file
> in the unzipped .egg, copied it to matplotlib, and everybody seems to be
> happy.
> john
>
>
>
> David Andrews wrote:
> > Part of the problem would appear to have been me borking the install
> > of gfortran - reinstalling the binaries for it has fixed the scipy
> > issue.  The issue with pylab not working persists - should this
> > superpack provide a full working install of matplotlib/pylab?  I
> > remember a while back having to fight with backends for it, though
> > that doesnt appear to have a bearing on the current problem i'm
> > having.
> >
> > Thanks for the quick reply Conor,
> >
> > Cheers,
> >
> > Dave
> >
> >
> >
> >>> "/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/site-packages/pylab.py",
> >>> line 1, in ?
> >>>     from matplotlib.pylab import *
> >>> ImportError: No module named matplotlib.pylab
> >>>
> >>> So any suggestions?
> >>>
> >>>
> >
> _______________________________________________
> SciPy-user mailing list
> SciPy-user at scipy.org
> http://projects.scipy.org/mailman/listinfo/scipy-user
>


More information about the SciPy-user mailing list