[SciPy-user] matplotlib fails to run with latest scipy/numpy release

fred fredmfp at gmail.com
Thu Sep 21 16:34:57 CDT 2006


Hi all,

I have just updated scipy (0.5.2.dev2209) and numpy (1.0.dev3204) and
now, matplotlib (0.87-4)
fails to run :-(

./> python
Python 2.4.3 (#1, Aug 10 2006, 09:25:31)
[GCC 3.3.5 (Debian 1:3.3.5-13)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import pylab
Traceback (most recent call last):
  File "<stdin>", line 1, in ?
  File "/usr/local/lib/python2.4/site-packages/pylab.py", line 1, in ?
    from matplotlib.pylab import *
  File "/usr/local/lib/python2.4/site-packages/matplotlib/pylab.py",
line 196, in ?
    import cm
  File "/usr/local/lib/python2.4/site-packages/matplotlib/cm.py", line
5, in ?
    import colors
  File "/usr/local/lib/python2.4/site-packages/matplotlib/colors.py",
line 33, in ?
    from numerix import array, arange, take, put, Float, Int, where, \
  File
"/usr/local/lib/python2.4/site-packages/matplotlib/numerix/__init__.py",
line 74, in ?
    Matrix = matrix
NameError: name 'matrix' is not defined

What's wrong ?

Cheers,

-- 
« Python, c'est un peu comme la baïonnette en 14, faut toujours sortir avec,
et pas hésiter d'en mettre un coup en cas de besoin. »
J.-Ph. D.



More information about the SciPy-user mailing list