[SciPy-user] matplotlib and scipy.stats on Tiger

Steve Lianoglou lists.steve at arachnedesign.net
Thu Sep 21 20:56:31 CDT 2006


Hi John,

> Has anyone found a way to get both scipy.stats and matplot lib to  
> work on Tiger?

I've been installing matplotlib/scipy/numpy from SVN and all seems to  
work fine -- numpy passes all tests, scipy does not (but this has  
been brought up in the list before). Honestly I haven't had much need  
to use scipy, as most of what I've been doing has been focused on  
numpy, so I can't say how bad those scipy test failures are (I  
believe there are 2).

> Installing scipy 0.5.1 from undefined.org lets me import scipy, but  
> if i try to import scipy.stats I get
>
> Traceback (most recent call last):
>   File "<pyshell#3>", line 1, in -toplevel-
>     import scipy.stats
...

Importing scipy.stats on my machine gives me no errors/warnings.

I'm running OS X.4.7 on a MacBook Pro.

You might think it's slightly more inconvenient working from svn, but  
I like it since numpy is constantly improving and I like to get those  
in my workspace asap.

Usually I don't have to update matplotlib, but I do every now and  
again just because it gives me something to do to take a break from  
my 'real work' and still makes me feel like I'm being productive :-)

HTH,
-steve


More information about the SciPy-user mailing list