[SciPy-user] Installation problems Mac OS X 10.4.7

Russell E. Owen rowen at cesmail.net
Fri Sep 22 14:08:12 CDT 2006


In article 
<a96756f30609161751x5e6cfb99t50be212e4b4c4716 at mail.gmail.com>,
 "Helmut Strey" <streycats at gmail.com> wrote:

> I have been trying to install the SciPy Superpack for Python.  I used
> MacPython2.4. When I try to import pylab the following error message
> appears:...
> 
> It seems that the package expects libfreetype6.dylib in
> /usr/local/lib. I found it in /usr/X11R6/lib.  I tried to create a
> symbolic link but then it says that the compiler versions dont match.
> What should I do?

It sounds as if the matplotlib included with the SciPy SuperPack is 
dynamically linked to libfreetype. Oops.

I suggest you install SciPy SuperPack first, then install matplotlib 
from <http://pythonmac.org/packages>. (Or, if you want to use TkAgg with 
a decent version of Tcl/Tk, I can send you an installer; the one 
presently at pythonmac only works with Apple's icky built-in Tcl/Tk).

Or you could try installing libfreetype (and you'll probably need libpng 
as well). I just posted instructions for building matplotlib on the 
matplotlib mailing list, and it includes instructions for building both 
libraries.

-- Russell



More information about the SciPy-user mailing list