[SciPy-user] RE : RE : RE : RE : RE : RE : Compiling numpy and scipy onAIX 5.3

Langella Raphael raphael.langella@steria.cnes...
Thu Apr 5 05:11:11 CDT 2007


> -----Message d'origine-----
> De : scipy-user-bounces@scipy.org 
> [mailto:scipy-user-bounces@scipy.org] De la part de Langella Raphael
> Envoyé : jeudi 5 avril 2007 10:17
> À : SciPy Users List
> Objet : [SciPy-user] RE : RE : RE : RE : RE : Compiling numpy 
> and scipy onAIX 5.3
> 
> 
> > -----Message d'origine-----
> > De : scipy-user-bounces@scipy.org
> > [mailto:scipy-user-bounces@scipy.org] De la part de David M. Cooke
> > Envoyé : mercredi 4 avril 2007 20:11
> > À : SciPy Users List
> > Objet : Re: [SciPy-user] RE : RE : RE : RE : Compiling numpy 
> > and scipy on AIX 5.3
> > 
> > 
> > -----BEGIN PGP SIGNED MESSAGE-----
> > Hash: SHA1
> > 
> > Langella Raphael wrote:
> > >> Langella Raphael wrote:
> > >>>>> I'd love to try the SVN version, but :
> > >>>>>
> > >>>>> $ svn co http://svn.scipy.org/svn/numpy/trunk numpy
> > >>>>> svn: PROPFIND request failed on '/svn/numpy/trunk'
> > >>>>> svn: PROPFIND of '/svn/numpy/trunk': 500 Server Error (http://
> > >>>>> svn.scipy.org)
> > >>>>>
> > >>>>> Am I missing something or is it a server problem as the error 
> > >>>>> message suggests ?
> > >>>> I copy/pasted your `svn co ..` command into my terminal
> > >> and it looks
> > >>>> like it's working fine for me ...
> > >>> So, it's probably a proxy problem. I'll try from home...
> > >> If it's a proxy problem, using https instead of http 
> will probably 
> > >> work.
> > > 
> > > Indeed. So here's what the SVN version gives me :
> > > 
> > > creating build/temp.aix-5.3-2.5/numpy/core/blasdot
> > > compile options: '-DNO_ATLAS_INFO=1 -Inumpy/core/blasdot
> > > -Inumpy/core/include -Ibuild/src.aix-5.3-2.5/numpy/core 
> > -Inumpy/core/src -Inumpy/core/include
> > 
> -I/Produits/publics/powerpc.AIX.5.2/python/2.5.0/include/python2.5 -c'
> > > cc_r: numpy/core/blasdot/_dotblas.c
> > > Traceback (most recent call last):
> > >   File "setup.py", line 89, in <module>
> > >     setup_package()
> > >   File "setup.py", line 82, in setup_package
> > >     configuration=configuration )
> > >   File "/tmp/numpy/numpy/distutils/core.py", line 174, in setup
> > >     return old_setup(**new_attr)
> > >   File "/usr/local/lib/python2.5/distutils/core.py", line
> > 151, in setup
> > >   File "/usr/local/lib/python2.5/distutils/dist.py", line
> > 974, in run_commands
> > >   File "/usr/local/lib/python2.5/distutils/dist.py", line
> > 994, in run_command
> > >   File "/tmp/numpy/numpy/distutils/command/install.py",
> > line 16, in run
> > >     r = old_install.run(self)
> > >   File
> > "/usr/local/lib/python2.5/distutils/command/install.py", line
> > 506, in run
> > >   File
> > "/Produits/publics/powerpc.AIX.5.2/python/2.5.0/lib/python2.5/
> > cmd.py", line 333, in run_command
> > >     del help[cmd]
> > >   File "/usr/local/lib/python2.5/distutils/dist.py", line
> > 994, in run_command
> > >   File
> > "/usr/local/lib/python2.5/distutils/command/build.py", line
> > 112, in run
> > >   File
> > "/Produits/publics/powerpc.AIX.5.2/python/2.5.0/lib/python2.5/
> > cmd.py", line 333, in run_command
> > >     del help[cmd]
> > >   File "/usr/local/lib/python2.5/distutils/dist.py", line
> > 994, in run_command
> > >   File "/tmp/numpy/numpy/distutils/command/build_ext.py",
> > line 121, in run
> > >     self.build_extensions()
> > >   File
> > "/usr/local/lib/python2.5/distutils/command/build_ext.py",
> > line 407, in build_extensions
> > >   File "/tmp/numpy/numpy/distutils/command/build_ext.py",
> > line 335, in build_extension
> > >     build_temp=self.build_temp,**kws)
> > >   File "/usr/local/lib/python2.5/distutils/ccompiler.py",
> > line 845, in link_shared_object
> > >   File "/tmp/numpy/numpy/distutils/fcompiler/__init__.py",
> > line 496, in link
> > >     self.spawn(command)
> > >   File "/tmp/numpy/numpy/distutils/ccompiler.py", line 29,
> > in CCompiler_spawn
> > >     display = ' '.join(list(display))
> > > TypeError: sequence item 0: expected string, list found
> > 
> > Ah, oops. Try it now.
> 
> OK, compilation works fine without any optimization. As soon 
> as I try to link with blas, lapack, atlas or essl, I get the 
> following errors : compile options: '-Inumpy/core/src 
> -Inumpy/core/include -I/usr/local/include/python2.5 -c'
> cc_r: _configtest.c
> cc_r _configtest.o -o _configtest
> ld: 0711-317 ERROR: Undefined symbol: .exp
> ld: 0711-345 Use the -bloadmap or -bnoquiet option to obtain 
> more information.
> ld: 0711-317 ERROR: Undefined symbol: .exp
> ld: 0711-345 Use the -bloadmap or -bnoquiet option to obtain 
> more information. failure.
> removing: _configtest.c _configtest.o
> 
> /usr/local/lib/python2.5/config/ld_so_aix cc_r 
> -bI:/usr/local/lib/python2.5/config/python.exp 
> build/temp.aix-5.3-2.5/numpy/core/blasdot/_dotblas.o 
> -L/usr/lib -lblas -o build/lib.aix-5.3-2.5/numpy/core/_dotblas.so
> ld: 0711-317 ERROR: Undefined symbol: .cblas_cdotc_sub
> ld: 0711-317 ERROR: Undefined symbol: .cblas_zdotc_sub
> ld: 0711-317 ERROR: Undefined symbol: .cblas_sdot
> ld: 0711-317 ERROR: Undefined symbol: .cblas_ddot
> ld: 0711-317 ERROR: Undefined symbol: .cblas_caxpy
> ld: 0711-317 ERROR: Undefined symbol: .cblas_saxpy
> ld: 0711-317 ERROR: Undefined symbol: .cblas_zaxpy
> ld: 0711-317 ERROR: Undefined symbol: .cblas_daxpy
> ld: 0711-317 ERROR: Undefined symbol: .cblas_cdotu_sub
> ld: 0711-317 ERROR: Undefined symbol: .cblas_zdotu_sub
> ld: 0711-317 ERROR: Undefined symbol: .cblas_cgemv
> ld: 0711-317 ERROR: Undefined symbol: .cblas_sgemv
> ld: 0711-317 ERROR: Undefined symbol: .cblas_zgemv
> ld: 0711-317 ERROR: Undefined symbol: .cblas_dgemv
> ld: 0711-317 ERROR: Undefined symbol: .cblas_cgemm
> ld: 0711-317 ERROR: Undefined symbol: .cblas_zgemm
> ld: 0711-317 ERROR: Undefined symbol: .cblas_sgemm
> ld: 0711-317 ERROR: Undefined symbol: .cblas_dgemm
> ld: 0711-345 Use the -bloadmap or -bnoquiet option to obtain 
> more information. building 'numpy.lib._compiled_base' 
> extension compiling C sources C compiler: cc_r -DNDEBUG -O
> 
> /usr/local/lib/python2.5/config/ld_so_aix cc_r 
> -bI:/usr/local/lib/python2.5/config/python.exp 
> build/temp.aix-5.3-2.5/numpy/linalg/lapack_litemodule.o 
> -L/usr/local/lib -lflapack -lfblas -o 
> build/lib.aix-5.3-2.5/numpy/linalg/lapack_lite.so
> ld: 0711-317 ERROR: Undefined symbol: .zungqr_
> ld: 0711-317 ERROR: Undefined symbol: .zgeqrf_
> ld: 0711-317 ERROR: Undefined symbol: .zpotrf_
> ld: 0711-317 ERROR: Undefined symbol: .zgetrf_
> ld: 0711-317 ERROR: Undefined symbol: .zgesdd_
> ld: 0711-317 ERROR: Undefined symbol: .zgesv_
> ld: 0711-317 ERROR: Undefined symbol: .zgelsd_
> ld: 0711-317 ERROR: Undefined symbol: .zgeev_
> ld: 0711-317 ERROR: Undefined symbol: .dorgqr_
> ld: 0711-317 ERROR: Undefined symbol: .dgeqrf_
> ld: 0711-317 ERROR: Undefined symbol: .dpotrf_
> ld: 0711-317 ERROR: Undefined symbol: .dgetrf_
> ld: 0711-317 ERROR: Undefined symbol: .dgesdd_
> ld: 0711-317 ERROR: Undefined symbol: .dgesv_
> ld: 0711-317 ERROR: Undefined symbol: .dgelsd_
> ld: 0711-317 ERROR: Undefined symbol: .zheevd_
> ld: 0711-317 ERROR: Undefined symbol: .dsyevd_
> ld: 0711-317 ERROR: Undefined symbol: .dgeev_
> ld: 0711-345 Use the -bloadmap or -bnoquiet option to obtain 
> more information.

The problem comes from my version of lapack. I tried another one, which somebody else had already compiled and it works :)
But there's still the problem of scipy not finding my C++ compiler, or invoking the wrong one.


More information about the SciPy-user mailing list