[SciPy-user] scipy install error

Ranjit Chacko rjchacko@gmail....
Sun Apr 8 11:04:46 CDT 2007


I just installed python and scipy from here:
http://pythonmac.org/packages/py24-fat/index.html

When I tried to import modules from scipy I got the following error:

>>> from scipy import *
RuntimeError: module compiled against version 1000002 of C-API but this
version of numpy is 1000009

Traceback (most recent call last):
  File "<pyshell#0>", line 1, in -toplevel-
    from scipy import *
  File
"/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/site-packages/scipy/io/__init__.py",
line 8, in -toplevel-
    from numpyio import packbits, unpackbits, bswap, fread, fwrite, \
ImportError: numpy.core.multiarray failed to import

How do I fix this?

Thanks,

Ranjit
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://projects.scipy.org/pipermail/scipy-user/attachments/20070408/4f03fe46/attachment.html 


More information about the SciPy-user mailing list