[SciPy-user] Plea: Installing SciPy on Mac 10.4.9: _fftpack.so problems?

Zachary Pincus zpincus@stanford....
Wed Apr 11 20:49:52 CDT 2007


Hi Ariel,

Are you in fact using gcc 3.3? If so, note that gfortran must be used  
with gcc 4. As per the instructions on the page you referenced, first  
run 'sudo gcc_select 4.0' to start using gcc 4 before building scipy.

As for scipy not being available in python ("no module named scipy"),  
it stands to reason that since the build process terminated in an  
error, it would not be usable and hence not be installed.

Finally, if the above does not fix the problem, it would be helpful  
if in the future you could include the actual error lines in your  
message. These are the lines immediately before the  the "failed with  
exit status" lines that you copied to the bottom of the last email.  
These error lines can be distinguished as they should attempt to  
provide a (likely cryptic) error message somewhat more revealing than  
"failed".

Best luck,
Zach


On Apr 11, 2007, at 6:20 PM, Ariel Rokem wrote:

> Hi - I have been having a very similar problem building scipy.
>
> I am running Mac OS10.4.9 on a PPC with gfortran 4.3.0 and gcc3.3
> I was running:
>
> ariel-rokems-ibook-g4:~ ariel$ python setup.py build_src build_clib  
> --fcompiler=gnu95 build_ext --fcompiler=gnu95 build
>
> as instructed here : http://scipy.org/Installing_SciPy/Mac_OS_X
>
> But it doesn't seem to work:
>
> ariel-rokems-ibook-g4:~ ariel$ python
> Python 2.4.4 (#1, Oct 18 2006, 10:34:39)
> [GCC 4.0.1 (Apple Computer, Inc. build 5341)] on darwin
> Type "help", "copyright", "credits" or "license" for more information.
> >>> import scipy
> Traceback (most recent call last):
>   File "<stdin>", line 1, in ?
> ImportError: No module named scipy
>
>
> This is the end of the build proccess. Looks ominous, but I am  
> puzzled ~:-?
>
> <yada, yada>
> error: Command "gcc -arch ppc -arch i386 -isysroot /Developer/SDKs/ 
> MacOSX10.4u.sdk -fno-s
> rict-aliasing -Wno-long-double -no-cpp-precomp -mno-fused-madd -fno- 
> common -dynamic -DNDE
> UG -g -O3 -DUSE_VENDOR_BLAS=1 -c Lib/linsolve/SuperLU/SRC/zgscon.c - 
> o build/temp.macosx-1
> .3-fat-2.4/Lib/linsolve/SuperLU/SRC/zgscon.o" failed with exit  
> status 1
>
>
> Nick - is this the issue you had? Did you manage to solve it?
>
> Thanks,
>
> Ariel
> _______________________________________________
> SciPy-user mailing list
> SciPy-user@scipy.org
> http://projects.scipy.org/mailman/listinfo/scipy-user



More information about the SciPy-user mailing list