[SciPy-user] building scipy from source on Mac Os X 10.4 ppc

Zachary Pincus zpincus@stanford....
Fri Aug 17 10:53:18 CDT 2007


Hello all,

> Samuel M. Smith wrote:
>> I erased the svn directory rechecked out and rebuilt without the
>> sudo, same error.
>
> Huh. Does your environment include MACOSX_DEPLOYMENT_TARGET  
> anywhere? Which
> compilers, gcc and gfortran, are you using?

I have also repeatedly run into the MACOSX_DEPLOYMENT_TARGET error on  
OS X PPC (cf. my earlier messages to this list on the subject).

In my experience, the issue has been the gfortran version. The latest  
version of the gfortran compiler from hpc.sourceforge.net causes this  
error for me (regardless of any environment settings for  
MACOSX_DEPLOYMENT_TARGET). The previous revision of the compiler from  
that site works fine, and the compiler at r.research.att.com/tools  
works properly in this regard in my hands as well. (The  
r.research.att.com/tools one can build proper universal binaries,  
too, and is now my preference.)

I'd be curious to see if this is Dr. Smith's problem as well.

I'm not sure if the error is triggered by any specific scipy version,  
or if it's due just to some gremlin in the hpc.sourceforge.net  
compiler -- I've never managed to track it down with any more  
specificity than what I reported above.

Zach Pincus




More information about the SciPy-user mailing list