[SciPy-user] Error in scipy.test(10) even after compiling successfully- Mac OS X 10.4.11 Apple GCC 4.0.1

Joshua Lippai discerptor@gmail....
Mon Dec 3 04:03:16 CST 2007


On Nov 29, 2007 5:58 PM, David Cournapeau <david@ar.media.kyoto-u.ac.jp> wrote:
>
> Joshua Lippai wrote:
> > Hello all,
> >
> > After building scipy, I ran the scipy tests and got this error in check_integer:
> >
> > ======================================================================
> > ERROR: check_integer (scipy.io.tests.test_array_import.TestReadArray)
> > ----------------------------------------------------------------------
> > Traceback (most recent call last):
> >   File "/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-packages/scipy/io/tests/test_array_import.py",
> > line 55, in check_integer
> >     from scipy import stats
> >   File "/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-packages/scipy/stats/__init__.py",
> > line 7, in <module>
> >     from stats import *
> >   File "/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-packages/scipy/stats/stats.py",
> > line 191, in <module>
> >     import scipy.special as special
> >   File "/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-packages/scipy/special/__init__.py",
> > line 8, in <module>
> >     from basic import *
> >   File "/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-packages/scipy/special/basic.py",
> > line 8, in <module>
> >     from _cephes import *
> > ImportError: dlopen(/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-packages/scipy/special/_cephes.so,
> > 2): Symbol not found: __gfortran_pow_r8_i4
> >   Referenced from:
> > /Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-packages/scipy/special/_cephes.so
> >   Expected in: dynamic lookup
> >
> > It would appear it's not finding a symbol for gfrotran in one of the
> > files, and this in turn makes it impossible to import _cephes. How
> > would I go about remedying this?
> >
> This symbol is in the gfortran runtime. We need the complete build log
> to be sure about the exact problem, but I expect some mismatch between
> fortran compilers (do you have several fortran compilers on your machine ?).
>
> cheers,
>
> David
>
> _______________________________________________
> SciPy-user mailing list
> SciPy-user@scipy.org
> http://projects.scipy.org/mailman/listinfo/scipy-user
>

That sounds about right... looking at the build dialog, certain
commands seem to want to use gnu95 while the others want gfortran.

unifing config_fc, config, build_clib, build_ext, build commands
--fcompiler options
  commands have different --fcompiler options: ['gfortran', 'gnu95'],
using first in list as default

I tried setting the --fcompiler option for all of the commands
mentioned there to gfortran (at least it changed the default from
gnu95 to gfortran like I wanted), but it still gives that message.
Anything else I can do to make this confusion for the compiler go
away?

Josh


More information about the SciPy-user mailing list