[SciPy-user] Mayavi2 installation woes (OS X 10.4.11, Python 2.5)

William Henney whenney@gmail....
Wed Dec 19 00:10:59 CST 2007


Hi list,

I have been trying to install MayaVi2 on an intel Mac running 10.4.11, but I am
running into a brick wall. 

I have been trying to follow the instructions I have found in various threads on
this list and at https://svn.enthought.com/enthought/wiki/IntelMacPython25. I
have managed to install all the dependencies (vtk, pyrex, wxpython, etc) but I
just can't get the enthought.traits package to build. 

I have tried the versions from the SVN repo and also the tar balls from
http://code.enthought.com/downloads/source/ets2.6/ but I always get the error
when building enthought.traits:

TypeError: swig_sources() takes exactly 3 arguments (2 given)

An example of a full stack trace is given below. It seems that the problem has
something to do with setuptools, and possibly with pyrex. I was initially using
setuptools 0.6c7 and Pyrex 0.9.6.4, but after reading negative comments about
0.9.6, I downgraded to 0.9.5.1a, although this makes no difference. 

I have also tried using the latest development version of setuptools
(0.7a1dev-r58661), but this doesn't work at all due to problems with "Namespace
Packages" (with 0.6 these just give a warning, as seen in the output below). 

Does anyone have any idea how to solve this?

Cheers

Will Henney 


$ python setup.py build
running build
running build_py
WARNING: enthought is a namespace package, but its __init__.py does
not declare_namespace(); setuptools 0.7 will REQUIRE this!
(See the setuptools manual under "Namespace Packages" for details.)

WARNING: enthought.traits is a namespace package, but its __init__.py does
not declare_namespace(); setuptools 0.7 will REQUIRE this!
(See the setuptools manual under "Namespace Packages" for details.)

WARNING: enthought.traits.ui is a namespace package, but its __init__.py does
not declare_namespace(); setuptools 0.7 will REQUIRE this!
(See the setuptools manual under "Namespace Packages" for details.)

running egg_info
writing requirements to enthought.traits.egg-info/requires.txt
writing enthought.traits.egg-info/PKG-INFO
writing namespace_packages to enthought.traits.egg-info/namespace_packages.txt
writing top-level names to enthought.traits.egg-info/top_level.txt
writing dependency_links to enthought.traits.egg-info/dependency_links.txt
reading manifest file 'enthought.traits.egg-info/SOURCES.txt'
writing manifest file 'enthought.traits.egg-info/SOURCES.txt'
running build_ext
building 'enthought.traits.ctraits' extension
Traceback (most recent call last):
  File "setup.py", line 72, in <module>
    zip_safe = False,
  File
"/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/
distutils/core.py",
line 151, in setup
    dist.run_commands()
  File
"/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/
distutils/dist.py",
line 974, in run_commands
    self.run_command(cmd)
  File
"/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/
distutils/dist.py",
line 994, in run_command
    cmd_obj.run()
  File
"/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/
distutils/command/build.py",
line 112, in run
    self.run_command(cmd_name)
  File
"/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/
distutils/cmd.py",
line 333, in run_command
    self.distribution.run_command(command)
  File
"/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/
distutils/dist.py",
line 994, in run_command
    cmd_obj.run()
  File
"/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/
site-packages/setuptools-0.6c7-py2.5.egg/setuptools/command/build_ext.py",
line 46, in run
  File
"/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/
distutils/command/build_ext.py",
line 290, in run
    self.build_extensions()
  File
"/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/
site-packages/Pyrex/Distutils/build_ext.py",
line 82, in build_extensions
    self.build_extension(ext)
  File
"/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/
site-packages/setuptools-0.6c7-py2.5.egg/setuptools/command/build_ext.py",
line 175, in build_extension
  File
"/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/
distutils/command/build_ext.py",
line 453, in build_extension
    sources = self.swig_sources(sources, ext)
  File
"/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/
site-packages/setuptools-0.6c7-py2.5.egg/setuptools/command/build_ext.py",
line 77, in swig_sources
TypeError: swig_sources() takes exactly 3 arguments (2 given)




More information about the SciPy-user mailing list