[SciPy-user] SciPy finds wrong lapack

J Oishi joishi at amnh.org
Tue Jan 2 12:40:21 CST 2007


Sorry to be a pain, but I'm still not having any luck!

> [atlas]
> atlas_libs = lapack, f77blas, cblas, atlas
> library_dirs = /usr/local/lib/atlas
>
> Also, note the correction to the order of the libraries.
Hmm. I made both of these changes to both numpy and scipy site.cfg,  
and the error still persists. ldd continues to report linking to /usr/ 
lib versions. Looking through the output of

python setup.py install

scipy reports that it finds the atlas libraries in /usr/local/lib/atlas:

atlas_blas_threads_info:
Setting PTATLAS=ATLAS
Setting PTATLAS=ATLAS
Setting PTATLAS=ATLAS
   FOUND:
     libraries = ['lapack', 'f77blas', 'cblas', 'atlas']
     library_dirs = ['/usr/local/lib/atlas']
     language = c
     include_dirs = ['/usr/local/lib/atlas']

thanks again,

j 


More information about the SciPy-user mailing list