[SciPy-user] scipy installation problems for a newbie

Jonathan Kane seismic73 at yahoo.com
Tue Jan 16 00:23:07 CST 2007


Hi.  I am a newbie trying to install both numpy and scipy.  Numpy seems to have installed fine, but scipy gives me errors when I try certain operations.  Can anyone help?   

I am using an Intel Mac Mini with OS X 10.4.8.  I downloaded and installed the binaries for ActivePython.  Here is the readout when I start python

ActivePython 2.4.3 Build 11 (ActiveState Software Inc.) based on
Python 2.4.3 (#1, Apr  3 2006, 18:07:14) 
[GCC 4.0.1 (Apple Computer, Inc. build 5247)] on darwin
Type "help", "copyright", "credits" or "license" for more information.


Here is an example of when I try to load scipy modules:

>>> from numpy import matrix
>>> from scipy.linalg import inv, det, eig
Traceback (most recent call last):
  File "<stdin>", line 1, in ?
  File "/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/site-packages/scipy/linalg/__init__.py", line 8, in ?
    from basic import *
  File "/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/site-packages/scipy/linalg/basic.py", line 17, in ?
    from lapack import get_lapack_funcs
  File "/Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/site-packages/scipy/linalg/lapack.py", line 17, in ?
    from scipy.linalg import flapack
ImportError: Failure linking new module: /Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/site-packages/scipy/linalg/flapack.so: Library not loaded: /usr/local/lib/libgfortran.1.dylib
  Referenced from: /Library/Frameworks/Python.framework/Versions/2.4/lib/python2.4/site-packages/scipy/linalg/flapack.so
  Reason: image not found


What is going on??

Help if you can.  Thanks.

Jon
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://projects.scipy.org/pipermail/scipy-user/attachments/20070115/4d40399e/attachment.html 


More information about the SciPy-user mailing list