[SciPy-user] TimeSeriesPackage

Pierre GM pgmdevlist@gmail....
Mon Jul 9 17:32:22 CDT 2007


On Monday 09 July 2007 18:13:56 Krishnan Maheswaran wrote:
> Hi All,
Hello !

> I would appreciate any help on installing the scipy timeseries module
Yay, another user ! More feedback !

> ( I 
> had no problem installing the maskedarray package). Please see errors
> below.

So, looks like you're trying to install the package on Windows. Here's an 
excerpt from the archives (from Matt Knox, the codeveloper of TimeSeries):

"""
cygwin works pretty seamlessly on windows with python 2.5, so I'd recommend 
that approach. It doesn't require any special witchcraft that used to be 
needed for compiling extensions on windows with earlier versions of python. 
Here are some good general instructions for compiling extensions with cygwin 
and python 2.5:  http://boodebr.org/main/python/build-windows-extensions

Once you've followed the setup steps there, just open the cygwin shell and you 
can do "python setup.py build_ext -i" to build the extension in place in that 
same directory. Or I *believe* "python setup.py install" will compile the 
extension and install it in your site-packages directory if memory serves me 
correctly... but I haven't tried that in a while and don't have the necessary 
stuff setup on my pc here to test. You can even create a nice binary installer 
by doing "python setup.py bdist_wininst" if you want to pass it around to your 
friends and family :)
"""

I remember following this method when I had to install the package on my boss' 
computer (a Windows machine), and that did work seamlessly indeed when you 
have Python 2.5. Let us know how it goes.

Sincerely,
P.


More information about the SciPy-user mailing list