[SciPy-user] pynetcdf crashing on Python 2.5

Bill Dandreta wjdandreta@att....
Wed Jul 18 14:34:15 CDT 2007


I don't know if this has any bearing on your problem but Python 2.5 is 
hard masked on Gentoo do to problems on 64 bit systems with packages 
depending on numeric.

Ryan May wrote:
> Hi,
>
> I've been using Travis's pynetcdf package (0.7) for doing NetCDF IO for 
> a lot of my code.  I recently updated my Gentoo install to use Python 
> 2.5, and now previously working code crashes (segmentation fault, no 
> python exception) when I try to access an array of data.  A GDB 
> backtrace puts the error inside _netcdf.so. I haven't recompiled with 
> debugging symbols to try to track this down any further.
>
> Has anyone else had any problems with pynetcdf and python 2.5?
>
> I'm aware of the other options (scipy.sandbox.netcdf, 
> Scientific.IO.NetCDF, and pycdf).  Is there an accepted package for 
> NetCDF in python?
>
> Thanks,
>
> Ryan
>   
-- 
Bill

wjdandreta@att.net

Gentoo Linux X86_64 2.6.20-gentoo-r8

Reclaim Your Inbox with http://www.mozilla.org/products/thunderbird/

All things cometh to he who waiteth as long as he who waiteth worketh like hell while he waiteth.



More information about the SciPy-user mailing list