[SciPy-user] pynetcdf crashing on Python 2.5

Mary Haley haley@ucar....
Thu Jul 19 07:52:27 CDT 2007


On Jul 18, 2007, at 11:29 PM, David Cournapeau wrote:

> Mary Haley wrote:
>> Robert, sorry, you're right, this isn't a NumPy issue, but it
>> manifested itself when I tried to build NumPy. I built Python 2.5 (I
>> thought successfully), and then when I tried to build NumPy 1.0.3 I
>> got the error:
>>
>>     ImportError: No module named _md5
>>
> I got a similar problem when building python on a solaris machine. On
> Linux, I would strongly recommend using the python available in your
> distribution, though. What is the reason you built your own ?
>

I'm building software for other users, and I like to test it against 
the latest
versions of Python and NumPy, if possible. Also, we provide these 
precompiled
binaries to users, and like to have it available for a variety of 
software versions.

The other thing is that our systems tend to be a few versions behind in 
python
and it's usually just easier to "roll our own".

I ended up finding another Linux system that had an older version of 
SSL installed,
and I was able to get Python 2.5 fully built on it.

Thanks for everybody's suggestions.

--Mary



> _______________________________________________
> SciPy-user mailing list
> SciPy-user@scipy.org
> http://projects.scipy.org/mailman/listinfo/scipy-user



More information about the SciPy-user mailing list