[SciPy-user] reading .mat-files (Matlab 7)

Stefan van der Walt stefan@sun.ac...
Wed Jul 25 12:34:42 CDT 2007


Hi Rob

On Wed, Jul 25, 2007 at 11:05:28AM -0400, Rob Clewley wrote:
> scipy.io.loadmat from scipy 0.5.2 doesn't work on anything but v4
> files for me. I generated extremely simple mat files (one small matrix
> in 'test.mat') with my matlab 7.3 using the -v6, -v5, and -v4 options,
> and scipy complained with this in all but the -v4 case:

Matthew made a number of changes since v0.5.2, so you may need to
upgrade.  He included test data files from Matlab 4 through 7.1, all
which are loaded as part of the automated unit test suite.

If you send me your file, I'd be glad to check that it loads under the
latest version.

Regards
Stéfan


More information about the SciPy-user mailing list