[SciPy-user] Numpy/Scipy on AIX

David Cournapeau david@ar.media.kyoto-u.ac...
Sat Jul 28 06:51:22 CDT 2007


Marek Wojciechowski wrote:
> David Cournapeau <david <at> ar.media.kyoto-u.ac.jp> writes:
>
>   
>> Marek wrote:
>>     
>>> Thanks for your response, but I skipped the problem downloading svn
>>>       
> version
> of
>   
>>> numpy (previously i tried to install numpy-1.0.2), and this compiles
>>>       
> nicely.
>   
>>> But now i run into troubles with scipy. Namely, I get tons of
>>>       
> unresolved
>   
>>> symbols from lapack, for example:
>>>
>>> ld: 0711-317 ERROR: Undefined symbol: .sgemm_
>>>
>>> Any workaround for this? I know there is linker
>>>       
> option -brename:.sgemm_,.sgemm,
>   
>>> which can solve it but this si not a nice solution.
>>>
>>>
>>>       
>> We'll need more informations to help you. The most useful thing would be
>>     
>
>   
>> to know the output of python setup.py config for numpy and scipy.
>>
>> Also, did you used the release of scipy (0.5.2) or the svn version as
>>     
> well ?
>   
>> David
>>
>>     
>
> I'm using svn version of scipy. As far as i observed scipy 0.5.2 is not 
> compatibile with numpy-svn. Below i'm pasting what setup.py produces. I
> seems things are compiled and there is only linking problem with lapack.
> Thanks for help.
>   
Where are your blas and lapack coming from ? Did you compile them by 
yourself ? How ? (compiler, version, etc...)

David


More information about the SciPy-user mailing list