[SciPy-user] Problems installing scipy

David Cournapeau david@ar.media.kyoto-u.ac...
Tue Jul 31 20:57:01 CDT 2007


Alexander Dietz wrote:
> Hi,
>
> thanks for the tipps bot none of them are working!
>
> On 7/31/07, *David Cournapeau* < david@ar.media.kyoto-u.ac.jp 
> <mailto:david@ar.media.kyoto-u.ac.jp>> wrote:
>
>     Alexander Dietz wrote:
>     > Hi,
>     >
>     > I am trying to install scipy on my laptop, running FC5. I have
>     > installed numpy, so I downloaded the scipy-package and run the setup
>     > script which creates a warning only:
>     >
>     Note that to avoid all this hassle, there are some rpm for FC5 for
>     numpy
>     and scipy:
>
>     http://download.opensuse.org/repositories/home:/ashigabou/Fedora_Extras_5/
>     <http://download.opensuse.org/repositories/home:/ashigabou/Fedora_Extras_5/>
>
>
> I tried to install the rpm package, but, as I expected before, several 
> other packages are required to install scipy:
>
> error: Failed dependencies:
>         libblas.so.3 is needed by python-scipy-0.5.2-14.1.i386
>         liblapack.so.3 is needed by python-scipy-0.5.2-14.1.i386
>         python-numpy is needed by python-scipy-0.5.2-14.1.i386
Those are provided by the repository (that's the whole point :) ). You 
should add the repository for the method you are using (yum, or whatever 
else you are using). See the following for more details

http://en.opensuse.org/Build_Service/User

You can do it manually too, by downloading all the rpms from here:

http://download.opensuse.org/repositories/home:/ashigabou/Fedora_Extras_5/repodata/

For scipy, you need at least lapack3-3.0-devel, lapack3-3.0, refblas3 
and refblas3-devel.
>
> And as I pointed out, I have numpy installed already...
>
> Also, when running the setup script absolutely nothing gets installed. 
> This might be related to the warning printed out:
>
> /usr/lib/python2.4/distutils/dist.py:236: UserWarning: Unknown 
> distribution option: 'configuration'
>   warnings.warn(msg)
>
> Do I need a new version of 'distutils'? Any other idea in order to 
> install scipy?
No. Which numpy are you using ? The last release (1.0.3) is 
unfortunately unusable to build last release 0.5.2 at the moment (but 
the rpms above backport some changes from SVN to make it work, one more 
reason to use them :)).

I think it would be much easier to help you getting the rpm installed, 
if you want to get released versions working.

David


More information about the SciPy-user mailing list