[SciPy-user] Another error while installing scipy

David Cournapeau david@ar.media.kyoto-u.ac...
Tue Jul 31 21:00:08 CDT 2007


Robert Kern wrote:
> Alexander Dietz wrote:
>   
>> Hi,
>>
>> while trying to install scipy on my laptop (FC5, numpy 1.0.3) I
>> encountered finally an error never occured before. I would appreciate to
>> resolve this problem in order to get scipy installed.
>>     
>
>   
>>   File "Lib/odr/setup.py", line 9, in ?
>>     from numpy.distutils.misc_util import get_path, Configuration, dot_join
>> ImportError: cannot import name get_path
>>
>>
>> As far as I know I have all these lapack, blas and atlas packages
>> installed. Any ideas?
>>     
>
> I goofed before the 1.0.3 release. I thought that get_path() was only used
> internally; it *is* currently deprecated in favor of using the Configuration
> object. Lib/odr/setup.py is fixed in scipy SVN, though.
>
>   
Alexander, to install numpy and scipy, you should really try the rpms of 
the ashigabou repository, they take care of all those problems. It is 
just a matter to add the repository to your package manager, and then 
everything is taken care for you. The above problem is taken care of, 
for example :) (I backported some changes from svn to make it work).

David


More information about the SciPy-user mailing list