[SciPy-user] new problem with f2py --fcompiler=intelem no longer works.

George Nurser gnurser@googlemail....
Tue Jun 12 10:04:21 CDT 2007


On 08/06/07, George Nurser <gnurser@googlemail.com> wrote:
> First problem is now solved, thanks, but compilationstill fails with
> the second error, with None in version_cmd
>

If I replace None by '-V' in line 133 of /numpy/distutils/fcompiler/intel.py

viz, in class IntelEM64TFCompiler
    executables = {
        'version_cmd'  : ['<F77>', None],
--->
    executables = {
        'version_cmd'  : ['<F77>', '-V'],

it seems to run fine for me now.
On our machines (running ifort 9.1) -V is also the option for getting
the version for Intel32bit and Itanium machines, so I guess the same
thing needs to be done for
class IntelItaniumFCompiler
&
class IntelFCompiler

No idea about the VisualFCompilers

--George.


More information about the SciPy-user mailing list