[SciPy-user] can't build on OS X from SVN

Zachary Pincus zpincus@stanford....
Thu Jun 14 19:57:10 CDT 2007


>> For what it's worth, a different linker error seems to happen in the
>> same place with g77 / gcc3.3:
>>
>> % python setup.py config_fc --fcompiler=gnu build
>>
>> /usr/bin/ld: can't locate file for: -lgcc_s
>> collect2: ld returned 1 exit status
>> /usr/bin/ld: can't locate file for: -lgcc_s
>> collect2: ld returned 1 exit status
>
> You can't use g77 with a Universal Python (and thus gcc 4).

True indeed.

My python (2.4.3) was compiled from source for PPC, and before  
building scipy with g77, I switched to gcc3.3. (This is how I used to  
build scipy before it got better compatibility with gfortran on PPC  
macs.) Anyhow, I was just providing another data point about the  
failure I'd seen -- not sure if it was useful or not.

Zach


> -- 
> Robert Kern
>
> "I have come to believe that the whole world is an enigma, a  
> harmless enigma
>  that is made terrible by our own mad attempt to interpret it as  
> though it had
>  an underlying truth."
>   -- Umberto Eco
> _______________________________________________
> SciPy-user mailing list
> SciPy-user@scipy.org
> http://projects.scipy.org/mailman/listinfo/scipy-user



More information about the SciPy-user mailing list