[SciPy-user] scipy fblas.so functions not found

Fahd Sultan asefu@fooie....
Fri Jun 22 17:37:30 CDT 2007


I had to recompile the rpms from your src rpms since the rpms dont 
install on Redhat AS 4.4.

during the build of python-numpy I get this error:
(any ideas?) 
I couldn't find an aborted install anywhere, not sure whats going on 
with this RPM.

Charlie have you tried these src rpms yet?

Executing(%install): /bin/sh -e /var/tmp/rpm-tmp.45867
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd numpy-1.0.3
+ LANG=C
+ export LANG
+ unset DISPLAY
+ /usr/lib/rpm/find-debuginfo.sh /usr/src/redhat/BUILD/numpy-1.0.3
0 blocks
find: /var/tmp/python-numpy-1.0.3-build/usr/lib/debug: No such file or 
directory
+ /usr/lib/rpm/redhat/brp-compress
+ /usr/lib/rpm/redhat/brp-strip-static-archive /usr/bin/strip
+ /usr/lib/rpm/redhat/brp-strip-comment-note /usr/bin/strip /usr/bin/objdump
Processing files: python-numpy-1.0.3-13.4
error: File not found by glob: /var/tmp/python-numpy-1.0.3-build/usr/bin/*
error: File not found by glob: 
/var/tmp/python-numpy-1.0.3-build/usr/lib64/python*/site-packages/numpy
error: File not found by glob: 
/var/tmp/python-numpy-1.0.3-build/usr/lib64/python*/site-packages/numpy*.egg-info
error: File not found by glob: 
/var/tmp/python-numpy-1.0.3-build/usr/lib64/python*/site-packages/COMPATIBILITY
error: File not found by glob: 
/var/tmp/python-numpy-1.0.3-build/usr/lib64/python*/site-packages/scipy_compatibility
error: File not found by glob: 
/var/tmp/python-numpy-1.0.3-build/usr/lib64/python*/site-packages/site.cfg.example
Processing files: python-numpy-debuginfo-1.0.3-13.4


RPM build errors:
    File not found by glob: /var/tmp/python-numpy-1.0.3-build/usr/bin/*
    File not found by glob: 
/var/tmp/python-numpy-1.0.3-build/usr/lib64/python*/site-packages/numpy
    File not found by glob: 
/var/tmp/python-numpy-1.0.3-build/usr/lib64/python*/site-packages/numpy*.egg-info
    File not found by glob: 
/var/tmp/python-numpy-1.0.3-build/usr/lib64/python*/site-packages/COMPATIBILITY
    File not found by glob: 
/var/tmp/python-numpy-1.0.3-build/usr/lib64/python*/site-packages/scipy_compatibility
    File not found by glob: 
/var/tmp/python-numpy-1.0.3-build/usr/lib64/python*/site-packages/site.cfg.example



David Cournapeau wrote:
> Fahd Sultan wrote:
>   
>> I was trying the build on the same arch. I have managed to build 
>> scipy/numpy. Please read below of how I did it.
>>
>>     
> The fpic error has nothing to do with the compiler you are using 
> (assuming they are not buggy of course :) ), but all to do with the 
> packaging of the blas/lapack you got.
>
> Please note that working rpm for numpy and scipy, as well as working 
> blas/lapack are available there:
>
> http://software.opensuse.org/download/home:/ashigabou/
>
> I added support for 64 bits arch and Fedora Core 7 a few days ago. If 
> this does not work for you, I would like to hear it (I am the maintainer 
> of this repository, but do not use fedora, so even if I try to produce 
> good quality packages, there may be some errors).
>
> David
> _______________________________________________
> SciPy-user mailing list
> SciPy-user@scipy.org
> http://projects.scipy.org/mailman/listinfo/scipy-user
>
>   


More information about the SciPy-user mailing list