[SciPy-user] OSX _fitpack import problem

Andres Gonzalez-Mancera gonzalezmancera+scipy@gmail....
Mon Mar 5 12:30:32 CST 2007


David, I'm not an expert on the subject but I have Scipy installed on
Mac os 10.4.8. I wasn't successful using python 2.5 and so I
downgraded to 2.4 and everything builds out of the box with no
problems following the instructions. I don't know if the SVN version
plays nicer with 2.5 but the release version which I also used didn't.
Also remember to use:

sudo python setup.py config_fc --fcompiler=gnu95 build

if you have both g77 and gfortran installed.

I hope this helps,

Andres

On 3/5/07, scipy-user-request@scipy.org <scipy-user-request@scipy.org> wrote:
>
> Message: 2
> Date: Mon, 5 Mar 2007 00:43:12 -0800
> From: Dave <davbrow@gmail.com>
> Subject: [SciPy-user] OSX _fitpack import problem
> To: scipy-user@scipy.org
> Message-ID:
>         <588f52020703050043g9cfd772kc4dbb30ef27cfbe1@mail.gmail.com>
> Content-Type: text/plain; charset=ISO-8859-1; format=flowed
>
> I have not been able to build a completely working scipy for python
> 2.5 on OS X (PPC).  Much of it seems to work but I get an error when
> trying to import scipy.interpolate:
>
> /Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-packages/scipy/interpolate/fitpack.py
> in <module>()
>      32     'bisplrep', 'bisplev']
>      33 __version__ = "$Revision: 2252 $"[10:-1]
> ---> 34 import _fitpack
>      35 from numpy import atleast_1d, array, ones, zeros, sqrt, ravel,
> transpose, \
>      36      dot, sin, cos, pi, arange, empty, int32
>
> <type 'exceptions.ImportError'>:
> dlopen(/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-packages/scipy/interpolate/_fitpack.so,
> 2): Symbol not found: _e_wsle
>   Referenced from:
> /Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-packages/scipy/interpolate/_fitpack.so
>   Expected in: dynamic lookup
>
>
> I installed using instructions from the scipy web site
> (http://www.scipy.org/Installing_SciPy/Mac_OS_X).  Here's additional
> info.
>
> gfortran --version
> GNU Fortran 95 (GCC) 4.3.0 20061223 (experimental)
>
> gcc --version
> powerpc-apple-darwin8-gcc-4.0.1 (GCC) 4.0.1 (Apple Computer, Inc. build 5367)
>
> I installed scipy from the tar archive (scipy-0.5.2), not svn.
>
> In searching I found postings where others have had this problem over
> the last few months but I didn't find a solution.  Does anyone know
> what's going on and how this can be resolved?
>
> -- David
>
>
> ------------------------------

-- 
Andres Gonzalez-Mancera
Biofluid Mechanics Lab
Department of Mechanical Engineering
University of Maryland, Baltimore County
andres.gonzalez@umbc.edu
410-455-3347


More information about the SciPy-user mailing list