[SciPy-user] ld unknown flag macosx_version_min

Dan Schult dschult@colgate....
Mon Mar 19 11:19:25 CDT 2007


On Mar 17, 2007, at 4:27 PM, Robert Kern wrote:
> Dan Schult wrote:
>> I've got a Mac OSx 10.4.8 machine and am compiling
>> scipy according to the instructions on the webpage.  I've
>> got gcc 4.0.0 gfortran 4.3.0 fftw3.0 and svn versions of numpy
>> and scipy.   My python is version 2.5.
>> Building numpy goes smoothly, but when I try scipy I have an ld  
>> error.
>
> I have gcc 4.0.1 and gfortran 4.3.0 installed on my system, and I  
> do not see
> this problem. Can you try upgrading to the latest version of Xcode  
> (which should
> have gcc 4.0.1)? It's not coming from Python but, I suspect, gfortran.
> Robert Kern

Indeed-- after an almost 1Gig download of XCode 2.4.1 to get gcc 4.0.1
it compiled and runs. :)  The tests give me 4 failed, but these  
already have
been noted on the email list.

I assume if I had compiled gfortran with gcc4.0 it would have worked the
first time.  I always seem to have trouble when using precompiled  
binaries.
Thanks very much Robert for the helpful tip!


More information about the SciPy-user mailing list