[SciPy-user] Problems installing scipy 0.6 on FC5

David Cournapeau david@ar.media.kyoto-u.ac...
Tue Nov 27 03:43:15 CST 2007


Alexander Dietz wrote:
>  
>
>     Also, you could try to see which
>     flag make it fails, for example, does the following:
>
>     /usr/bin/g77 -g -Wall -fno-second-underscore -fPIC -O2 -funroll-loops
>     -march=i686 -mmmx -msse -fomit-frame-pointer -malign-double -c
>     scipy/fftpack/dfftpack/zfftb1.f
>
>
> That worked actually... 
Yes, so the problem is your gcc version. Maybe we could disable adding 
-msse2 altogether for gcc < 3.3, instead of enabling it for gcc > 3.2.2 
(look at numpy/distutils/fcompiler/gnu.py, and look for -msse2; if Pearu 
or David are reading this, maybe they know a better solution ?).

Note that FC5 is old. You should consider upgrading (FC 5 is not 
maintained anymore) if you can,

cheers,

David



More information about the SciPy-user mailing list