[SciPy-user] problem installing sciPy

David Cournapeau david@ar.media.kyoto-u.ac...
Fri Oct 5 07:03:08 CDT 2007


marco turchi wrote:
> Dear Davis,
> I need to install the new version of python, because the old one has 
> not the python-dev and the administrator of the machine told me that 
> he could not install it... do not ask me the reason :-(
Ah, ok. Then you do not seem to have any alternative, indeed.
> Do i need to install BLAS??? Where can i find it?
Yes, you need to install BLAS (and LAPACK as well). Either you can use 
RHEL packages for blas/lapack, or you need to compile them by yourself 
too. For that, you need a fortran compiler as well (if you have to 
install BLAS/LAPACK by yourself, you may be interested in my gar 
scripts: 
http://www.ar.media.kyoto-u.ac.jp/members/david/archives/garnumpy/garnumpy-0.3.tbz2, 
which makes the installation a bit easier: it installs everything from 
blas/lapack to scipy in a self contained directory, for cases exactly 
like yours where people do not have root rights).

cheers,

David


More information about the SciPy-user mailing list