[SciPy-user] problem installing sciPy

marco turchi marco.turchi@gmail....
Thu Oct 11 11:17:31 CDT 2007


Dear experts,
I have sent two file attached to a previous email which contain the errors
that I continue to get from the SciPy installation, but I guess they have
been blocked by the moderator.
Is there another way to send you the errors logs? The two files are quite
long so I cannot paste the content inside an email.

Thanks
Marco

On 10/6/07, David Cournapeau <david@ar.media.kyoto-u.ac.jp> wrote:
>
> marco turchi wrote:
> > Dear Chris,
> > I have just said to David that i have tried to install  numpy and
> > scipy using  python 2.3, but on that machine there is not python-dev,
> > and the administrator cannot install it, he has some problems with
> > licences.
> I really cannot see any license related problems with python-dev which
> would not be present in python. But I digress.
> > I guess that I cannot use rpm, because I'm not administrator. That's
> > the reason because I have installed in /usr/local another version of
> > Python and then I have followed the normal instruction for numpy and
> > scipy.
> >
> > The installation arrives to the end, but when I open Python, new or
> > old version, I can import Numpy, but I cannot import scipy, because
> > the module is not present.
> >
> > I can try another time to do everything from the beginning, but i do
> > not know how useful it can be.
> As Chris said: if you can get your administrator to install python-dev,
> blas and lapack, this is the easiest. If you can't, then garnumpy can
> help you. The principle of garnumpy is :
>     - to fetch the sources of all necessary softwares/libraries from
> internet
>     - build them with consistent compiler options
>     - install it in one location (for example, $HOME/garnumpyinstall,
> the default).
>
> I think this should be easier than compiling everything by yourself,
> specially if you are not familiar with building complicated packages.
> I've put a new version online, because I realized that I did not update
> the scripts for the new numpy/scipy versions. So remove the one you've
> download, and use this URL instead:
>
>
> http://www.ar.media.kyoto-u.ac.jp/members/david/archives/garnumpy/garnumpy-0.4.tbz2
>
> Most of the options should be changed in gar.conf.mk. For example,
> changing python -> change the line PYTHON to the full path of your
> python (e.g. /usr/local/bin/python in your case). In your case, this is
> the only required change.
>
> To build and install numpy/scipy with it, you do:
>     - make clean -> do this if you change anything in gar.conf.mk. Do it
> once you changed the python location.
>     - make garchive -> this will download everything.
>     - cd platform/scipy && make install -> this will build scipy and all
> the necessary softwares.
>
> If this fails, please paste all the output, because otherwise, it is
> difficult to see the exact problem. But if you have a C and fortran
> compiler, it should not fail,
>
> cheers,
>
> David
> _______________________________________________
> SciPy-user mailing list
> SciPy-user@scipy.org
> http://projects.scipy.org/mailman/listinfo/scipy-user
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://projects.scipy.org/pipermail/scipy-user/attachments/20071011/5d5c69f6/attachment.html 


More information about the SciPy-user mailing list