[SciPy-user] Python mode in emacs 22 (Ubuntu Gutsy Gibbon)

Ryan Krauss ryanlists@gmail....
Sun Oct 21 15:51:07 CDT 2007


O.K. something in my .emacs file was causing my problem.  I renamed it
so it wouldn't load and deleted the .emacs.elc file and the file
loaded correctly with the new built-in Python mode.  But it doesn't
seem as powerful.  It doesn't scan for functions and classes and it
doesn't auto-indent in for loops.  I think I have to remove emacs22
and roll back to 21 and reinstall the other python-mode, unless
someone has a better solution.

On 10/21/07, Ryan Krauss <ryanlists@gmail.com> wrote:
> So, I freely admit that this belongs on some other list, but the Emacs
> list people are often mean to me.  Maybe because I think python is
> better than lisp and I shouldn't have to learn lisp.....
>
> But I am having a problem with python-mode after upgrading to Ubuntu
> 7.10 Gutsy Gibbon (as predicted).  I tried purging python-mode as
> recommended using
>
> dpkg --purge python-mode
>
> but it doesn't seem to have worked.  Here is the result of "locate
> *pythonmode.el":
>
> ryan@am2:~$ locate *python*mode.el
> /mnt/RYANFAT/downloads/emacs/python-mode-1.0/doctest-mode.el
> /mnt/RYANFAT/downloads/emacs/python-mode-1.0/python-mode.el
> /mnt/RYANFAT/downloads/emacs/Emacs/lisp/python-mode.el
>
> None of those are on my emacs path.
>
> Here is my error message after trying to open a python file from the
> command line using
>
> emacs myfile.py
>
> "An error has occurred while loading `/home/ryan/.emacs.elc':
>
> File error: Cannot open load file, python-mode
>
> To ensure normal operation, you should investigate and remove the
> cause of the error in your initialization file.  Start Emacs with
> the `--debug-init' option to view a complete error backtrace.
>
> File mode specification error: (file-error "Cannot open load file"
> "python-mode")
> For information about the GNU Project and its goals, type C-h C-p."
>
> I believe I have commented out all python-mode commands in my .emacs
> file.  It is attached.
>
> Can anyone help me get python-mode working again?  Or do I have to
> post to the emacs list?
>
> Thanks,
>
> Ryan
>
> On 10/20/07, Daniel Lenski <dlenski@gmail.com> wrote:
> > On Sat, 20 Oct 2007 23:58:42 +0200, Joachim Dahl wrote:
> >
> > > Emacs22 has python mode integrated,  and having python-mode installed as
> > > a separate
> > > package causes problems.   Removing the python-mode package seems to fix
> > > it for Emacs22.
> > >
> > > - joachim
> >
> > Thanks, Joachim!!!  That did the trick.  I had to not only *remove* the python-mode package, but
> > purge its configuration files as well.  You can do that from the command line using:
> >
> > dpkg --purge python-mode
> >
> > For some reason unknown to me, the default behavior is to allow removed packages to leave config
> > files in place.
> >
> > Dan
> >
> > _______________________________________________
> > SciPy-user mailing list
> > SciPy-user@scipy.org
> > http://projects.scipy.org/mailman/listinfo/scipy-user
> >
>
>


More information about the SciPy-user mailing list