[SciPy-user] SciPY/NumPY - rhel4 installation issues....

bruce bedouglas@earthlink....
Wed Oct 31 23:45:07 CDT 2007


Hi.

I'm trying to install numpy/scipy on a rhel system with python v2.4.3

I'm following the information from various sites. My goal is to be able to
successfully get numpy/scipy up/running, with a few basic tests.

I'm using the tar files for:
	drwxr-xr-x  6 root  root     4096 Oct 31 19:30 .
	drwxr-xr-x 32 root  root     4096 Oct 31 12:26 ..
	drwxr-xr-x 12 root  root     4096 Oct 31 18:29 ATLAS
	-rw-r--r--  1 root  root  3192987 Oct 31 12:35 atlas3.8.0.tar.gz
	drwxr-x---  8 13686  731     4096 Oct 31 18:11 lapack-3.1.1
	-rw-r--r--  1 root  root 10407595 Feb 26  2007 lapack-3.1.1.tgz
	drwxrwxr-x  4 test  test     4096 Oct 31 19:43 numpy-1.0.3.1
	-rw-r--r--  1 root  root  1500255 Oct 31 12:49 numpy-1.0.3.1.tar.gz
	-rw-r--r--  1 root  root       54 Oct 31 12:27 readme.txt
	drwxrwxr-x  3 test  test     4096 Sep 22 01:14 scipy-0.6.0
	-rw-r--r--  1 root  root  6572954 Oct 31 12:52 scipy-0.6.0.tar.gz

I believe I've successfully downloaded/built/installed the atlas/lapack
apps.

I'm using a RHEL4 system with a single 1.8GHz. processor.

I did a:
  "python setup.py install" for numpy, and it appeared to finish.

I then did a:
  "python setup.py install" for scipy, and got the following err:
	[root@mfgtest3 <Branch GodzillaTest1.1.2> scipy-0.6.0]# python setup.py
install
	Traceback (most recent call last):
	  File "setup.py", line 53, in ?
	    setup_package()
	  File "setup.py", line 28, in setup_package
	    from numpy.distutils.core import setup
	  File "/usr/lib/python2.4/site-packages/numpy/__init__.py", line 39, in ?
	    import core
	  File "/usr/lib/python2.4/site-packages/numpy/core/__init__.py", line 5,
in ?
	    import multiarray
	ImportError: /usr/lib/python2.4/site-packages/numpy/core/multiarray.so:
undefined symbol: 	PyUnicodeUCS2_FromUnicode

I can't find  anything via google to indicate what's the cause...

Any thoughts/comments would be seriously helpful!!

Could this be an issue of incompatible versions between numpy/scipy??

thanks

-sam




More information about the SciPy-user mailing list