[SciPy-user] scipy 0.6.0 ImportError: cannot import name cscmux

fdu.xiaojf@gmai... fdu.xiaojf@gmai...
Fri Sep 21 10:18:15 CDT 2007


Jim Vickroy wrote:
> Hello,
> 
>  
> 
> I’ve just installed scipy 0.6.0 via scipy-0.6.0.win32-py2.5.msi.  The 
> installation appeared to proceed normally, but the scipy import had the 
> following result:
> 
>  
> 
> python version: 2.5 (r25:51908, Sep 19 2006, 09:52:17) [MSC v.1310 32 
> bit (Intel)]
> 
> Traceback (most recent call last):
> 
>   File "t-variant.py", line 4, in <module>
> 
>     from scipy import *
> 
>   File "C:\Python25\lib\site-packages\scipy\linsolve\__init__.py", line 
> 5, in <module>
> 
>     import umfpack
> 
>   File 
> "C:\Python25\lib\site-packages\scipy\linsolve\umfpack\__init__.py", line 
> 3, in <module>
> 
>     from umfpack import *
> 
>   File 
> "C:\Python25\lib\site-packages\scipy\linsolve\umfpack\umfpack.py", line 
> 11, in <module>
> 
>     import scipy.sparse as sp
> 
>   File "C:\Python25\lib\site-packages\scipy\sparse\__init__.py", line 5, 
> in <module>
> 
>     from sparse import *
> 
>   File "C:\Python25\lib\site-packages\scipy\sparse\sparse.py", line 21, 
> in <module>
> 
>     from scipy.sparse.sparsetools import cscmux, csrmux, \
> 
> ImportError: cannot import name cscmux
> 
>  
> 
> This did not happen with scipy 0.5.2.1.
> 
>  
> 
> I uninstalled and reinstalled the package, but the failure continues.
> 
>  
> 
> Apologies if this has been posted.  I am a new subscriber and did not 
> see this problem reported in the archive.
> 
>  
> 
It works for me. I'm running python2.5.1, and I installed scipy using 
scipy-0.6.0.win32-py2.5.exe.


More information about the SciPy-user mailing list