[SciPy-user] Warning about UMFPACK while build scipy-0.6.0 on Mac OSX PPC

Warren Weckesser warren.weckesser@gmail....
Wed Apr 16 19:10:58 CDT 2008


Hello again,

I am trying to build scipy-0.6.0 on a Mac running OSX 10.4 (PPC).  I have
python 2.5.2 installed; gcc is Apple's 4.0.1, and gfortran is version 4.2.1.

I am following the instructions here:
http://www.scipy.org/Installing_SciPy/Mac_OS_X

When I run this command:
   python setup.py build_src build_clib --fcompiler=gnu95 build_ext
--fcompiler=gnu95 build > build.out
the following message is printed to stderr:

/Users/wweckesser/test_install/lib/python2.5/site-packages/numpy/distutils/system_info.py:414:
UserWarning:
    UMFPACK sparse solver (http://www.cise.ufl.edu/research/sparse/umfpack/)
    not found. Directories to search for the libraries can be specified in
the
    numpy/distutils/site.cfg file (section [umfpack]) or by setting
    the UMFPACK environment variable.
  warnings.warn(self.notfounderror.__doc__)


I thought I had numpy installed correctly :(
numpy.test() reported no errors.

Am I supposed to install UMFPACK before numpy?  Do I need UMFPACK?  I don't
know what to make of that warning.

Warren
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://projects.scipy.org/pipermail/scipy-user/attachments/20080416/cdf65630/attachment.html 


More information about the SciPy-user mailing list