[SciPy-user] failure to build scipy on RHEL5

Lev Givon lev@columbia....
Fri Apr 25 10:58:54 CDT 2008


Received from Michael Hearne on Fri, Apr 25, 2008 at 11:42:54AM EDT:
> Paul - Thanks!  I took a first crack at installing these, and started with 
> BLAS.
>
> When I do "sudo rpm -i blas-3.1.1-2.el5.x86_64.rpm", I get a bunch of 
> conflicts...
>
> I then tried "sudo rpm -q blas" and was returned:
> blas-3.0-37.el5
> blas-3.0-37.el5
>
> I'm not terribly familiar with RH, as I use Ubuntu at home, does this mean 
> I have two instances of BLAS 3.0 already installed?  If so, is it safe to 
> use rpm to remove them?
>
> --Mike

The fact that the blas package is seemingly listed twice implies that
you probably have both the i386 and x86_64 versions of the package
installed. To see the architecture of the installed packages, try
using the following query:

sudo rpm -q --queryformat="%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}\n" blas

Removing the package that does not correspond to your machine's
architecture should be harmless.

						       L.G.


More information about the SciPy-user mailing list