[SciPy-user] rev 4595 broken

Robert Cimrman cimrman3@ntc.zcu...
Tue Aug 5 07:03:29 CDT 2008


Robert Cimrman wrote:
> Robert Kern wrote:
>> On Mon, Aug 4, 2008 at 08:29, Tommy Grav <tgrav@mac.com> wrote:
>>> I tried to install the current svn trunk and ran into this problem
>>>
>>> skathi:~] tgrav% python ActivePython 2.5.1.1 (ActiveState Software
>>> Inc.) based on Python 2.5.1 (r251:54863, May  1 2007, 17:40:00) 
>>> [GCC 4.0.1 (Apple Computer, Inc. build 5250)] on darwin Type
>>> "help", "copyright", "credits" or "license" for more information.
>>>>>> import numpy numpy.__version__
>>> '1.1.1'
>>>>>> import scipy
>>> Traceback (most recent call last): File "<stdin>", line 1, in
>>> <module> File
>>> "/Library/Frameworks/Python.framework/Versions/2.5/lib/ 
>>> python2.5/site-packages/scipy/__init__.py", line 86, in <module> 
>>> from numpy.testing import Tester ImportError: cannot import name
>>> Tester
>>> Is the current bleeding edge copy broken?
>> No. SVN scipy currently requires SVN numpy.
> 
> I have the same problem, and I cannot compile SVN numpy, see below. Do 
> you have an idea where does the problem come from?
> 
> r.
> 
> building 'numpy.core.multiarray' extension
> compiling C sources
> C compiler: i486-pc-linux-gnu-gcc -pthread -fno-strict-aliasing -DNDEBUG
> -fPIC
> 
> creating build/temp.linux-i686-2.4
> creating build/temp.linux-i686-2.4/numpy
> creating build/temp.linux-i686-2.4/numpy/core
> creating build/temp.linux-i686-2.4/numpy/core/src
> compile options: '-Ibuild/src.linux-i686-2.4/numpy/core/src
> -Inumpy/core/include -Ibuild/src.linux-i686-2.4/numpy/core/include/numpy
> -Inumpy/core/src -Inumpy/core/include -I/usr/include/python2.4
> -I/usr/include/python2.4 -c'
> i486-pc-linux-gnu-gcc: numpy/core/src/multiarraymodule.c
> numpy/core/src/multiarraymodule.c:130: error: static declaration of
> 'PyArray_OverflowMultiplyList' follows non-static declaration
> numpy/core/src/arrayobject.c:10185: error: previous implicit declaration
> of 'PyArray_OverflowMultiplyList' was here
> numpy/core/src/multiarraymodule.c:130: error: static declaration of
> 'PyArray_OverflowMultiplyList' follows non-static declaration
> numpy/core/src/arrayobject.c:10185: error: previous implicit declaration
> of 'PyArray_OverflowMultiplyList' was here
> error: Command "i486-pc-linux-gnu-gcc -pthread -fno-strict-aliasing
> -DNDEBUG -fPIC -Ibuild/src.linux-i686-2.4/numpy/core/src
> -Inumpy/core/include -Ibuild/src.linux-i686-2.4/numpy/core/include/numpy
> -Inumpy/core/src -Inumpy/core/include -I/usr/include/python2.4
> -I/usr/include/python2.4 -c numpy/core/src/multiarraymodule.c -o
> build/temp.linux-i686-2.4/numpy/core/src/multiarraymodule.o" failed with
> exit status 1

I have persuaded numpy to compile:
In [2]: nm.__version__
Out[2]: '1.2.0.dev5610'

$ gcc --version
gcc (GCC) 4.1.2 (Gentoo 4.1.2 p1.1)

I had to do:

Index: numpy/core/src/arrayobject.c
===================================================================
--- numpy/core/src/arrayobject.c        (revision 5610)
+++ numpy/core/src/arrayobject.c        (working copy)
@@ -44,6 +44,10 @@
      return priority;
  }

+static intp
+PyArray_OverflowMultiplyList(register intp *l1, register int n);
+
+
  static int
  _check_object_rec(PyArray_Descr *descr)
  {


More information about the SciPy-user mailing list