[SciPy-user] scipy on old CPU crashes

David Cournapeau cournape@gmail....
Wed Dec 3 21:15:27 CST 2008


On Wed, Dec 3, 2008 at 4:06 PM, David Cournapeau <cournape@gmail.com> wrote:
> On Tue, Dec 2, 2008 at 11:52 PM, David Cournapeau <cournape@gmail.com> wrote:
>> On Tue, Dec 2, 2008 at 4:36 PM, oyster <lepto.python@gmail.com> wrote:
>>> sorry, but scipy-0.7.0b1-win32-superpack-python2.4.exe and
>>> numpy-1.2.1-win32-superpack-python2.4.exe crash on my old pc too,
>>> which uses duron 750MHz. So now I think it is not the problem with
>>> non-sse/sse/sse2 instruction
>>>
>>
>
> Ok, I checked the machine code in scipy and it seems that the quadpack
> module (used by scipy.integrate) has a couple of SSE instructions.
> Code-wise, it is trivial to solve, but we may need a new numpy version
> for that.
>

Could you try this installer ?

http://www.ar.media.kyoto-u.ac.jp/members/david/archives/scipy/scipy-0.7.0.dev5213-win32-superpack-python2.4.exe

This one should hopefully contains no SSE instructions at all for old
CPU (the _quadpack.pyd contains no SSE2 instructions anymore), and
should work.

David


More information about the SciPy-user mailing list