[SciPy-user] minpack2.so not proper arch in 0.7.0b1 mac release binary?

Robert Kern robert.kern@gmail....
Fri Dec 5 13:13:51 CST 2008


On Fri, Dec 5, 2008 at 11:52, Tommy Grav <tgrav@mac.com> wrote:
> I installed the Mac OS X 0.7.0b1 binary from the scipy.org site, but I
> run into this
> error
>
> [skathi:myCode/Python/pyMPC] drtgrav% python -u comet_obs.py
> File /Users/drtgrav/Work/myLibrary/Catalogs/binEphemLong.405 has been
> opened
> Traceback (most recent call last):
>   File "comet_obs.py", line 6, in <module>
>     from scipy.optimize import leastsq
>   File "/Library/Frameworks/Python.framework/Versions/2.5/lib/
> python2.5/site-packages/scipy/optimize/__init__.py", line 7, in <module>
>     from optimize import *
>   File "/Library/Frameworks/Python.framework/Versions/2.5/lib/
> python2.5/site-packages/scipy/optimize/optimize.py", line 28, in
> <module>
>     import linesearch
>   File "/Library/Frameworks/Python.framework/Versions/2.5/lib/
> python2.5/site-packages/scipy/optimize/linesearch.py", line 3, in
> <module>
>     from scipy.optimize import minpack2
> ImportError: dlopen(/Library/Frameworks/Python.framework/Versions/2.5/
> lib/python2.5/site-packages/scipy/optimize/minpack2.so, 2): no
> suitable image found.  Did find:
>        /Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-
> packages/scipy/optimize/minpack2.so: mach-o, but wrong architecture
> [skathi:myCode/Python/pyMPC] drtgrav%
>
> Anyone know how to solve this problem?

It's not easy to build a Universal binary with Fortran extension
modules like scipy. The packager of this binary did not; the binaries
are for Intel Macs only.

-- 
Robert Kern

"I have come to believe that the whole world is an enigma, a harmless
enigma that is made terrible by our own mad attempt to interpret it as
though it had an underlying truth."
  -- Umberto Eco


More information about the SciPy-user mailing list