[SciPy-user] Problemds building NumPy with Python 2.6 / MinGW 3.4.5 on Windows XP SP3

Peter Maas fritz.peter.maas@googlemail....
Sat Dec 6 11:03:58 CST 2008


David Cournapeau schrieb:
> Unfortunately, you need to build numpy from svn if you wish to build
> numpy on python 2.6 with mingw ATM. No release of numpy  contains the
> necessary changes to build with python 2.6 yet

Hi David,

thanks for your advice. I just checked out numpy

svn co http://scipy.org/svn/numpy/trunk numpy

and repeated the build command

python setup.py build -c mingw32

The result:

[...]
running build_src
building py_modules sources
creating build
creating build\src.win32-2.6
creating build\src.win32-2.6\numpy
creating build\src.win32-2.6\numpy\distutils
building extension "numpy.core.multiarray" sources
creating build\src.win32-2.6\numpy\core
Generating build\src.win32-2.6\numpy\core\include/numpy\config.h
C:\home\peter\projekte\scipy\archiv\svn-6139\numpy\numpy\distutils\command\config.py:35: DeprecationWarning:
+++++++++++++++++++++++++++++++++++++++++++++++++
Usage of try_run is deprecated: please do not
use it anymore, and avoid configuration checks
involving running executable on the target machine.
+++++++++++++++++++++++++++++++++++++++++++++++++

  DeprecationWarning)
error: None

Something has changed but the build still fails. Any idea which parts of numpy
conflict with Python2.6?

-- 

Regards, Peter.

Peter Maas, Aachen, Germany



More information about the SciPy-user mailing list