[SciPy-user] splinalg import error

Robin robince@gmail....
Wed Feb 13 09:19:14 CST 2008


Hi,

Having finally completed a successful build on 64 bit linux I followed
exactly the same procedure (which I added to the wiki) on a fresh
machine.

Unfortunately I now seem to have some fresh issues (which must be due
to a recent change in SVN). First splinalg wont import:

In [2]: scipy.__version__
Out[2]: '0.7.0.dev3934'

In [3]: import scipy.splinalg
---------------------------------------------------------------------------
<type 'exceptions.NameError'>             Traceback (most recent call last)

/usr/lib/python2.5/site-packages/scipy/splinalg/dsolve/<ipython
console> in <module>()

/usr/lib/python2.5/site-packages/scipy/splinalg/__init__.py in <module>()
      4
      5 from isolve import *
----> 6 from dsolve import *
      7 from interface import *
      8 from eigen import *

/usr/lib/python2.5/site-packages/scipy/splinalg/dsolve/__init__.py in <module>()
      7 del umfpack
      8
----> 9 from linsolve import *
     10
     11 __all__ = filter(lambda s:not s.startswith('_'),dir())

/usr/lib/python2.5/site-packages/scipy/splinalg/dsolve/linsolve.py in <module>()
     16     isUmfpack = hasattr( umfpack, 'UMFPACK_OK' )
     17
---> 18 if isUmfpack and noScikit:
     19     warn( 'scipy.splinalg.dsolve.umfpack will be removed,'
     20           ' install scikits.umfpack instead', DeprecationWarning )

<type 'exceptions.NameError'>: name 'isUmfpack' is not defined

think line 16 above needs to be taken out of the else clause.

However, even with this done, although scipy.splinalg.dsolve.umfpack
imports, it seems to be missing a lot of attributes, and in fact I
can't find __umfpack.so anywhere. Is it now necessary to use the
scikit, or is there something else wrong with my installation?

Robin


More information about the SciPy-user mailing list