[SciPy-user] Installing Scipy on OS X 10.4 - wrong architecture files

Jeffrey Fogel jeffrey.fogel@gmail....
Wed Feb 13 13:33:33 CST 2008


I have been trying to install scipy 0.6.0 from the source code onto my
Mac (10.4.11, Intel chip) and I'm having some trouble that I hope
someone here can help me with.  I try installing using:

python setup.py build
sudo python setup.py install

Which seems to compile and install scipy (with a number of warnings,
but no errors).  However, when I run scipy.test(1,10) it crashes with
the following error:

ImportError: dlopen(/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-packages/scipy/special/_cephes.so,
2): no suitable image found.  Did find:
        /Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/site-packages/scipy/special/_cephes.so:
mach-o, but wrong architecture

Looking in the directory mentioned above, a large number of the .so
files seem to be compiled for ppc instead of i386.  I have been unable
to find a switch for setup.py that sets the architecture.  Is there a
way to force the proper architecture so that I can get it to install
properly?

I am running python 2.5, also installed from the source from
python.org.  The compilers I'm using are gcc 4.0.1 and gfortran 4.1.0.
 Thanks for your help.

-Jeffrey


More information about the SciPy-user mailing list