[SciPy-user] splinalg import error

Robert Cimrman cimrman3@ntc.zcu...
Thu Feb 14 02:58:35 CST 2008


Nathan Bell wrote:
> On Feb 13, 2008 9:26 AM, Robin <robince@gmail.com> wrote:
>> On Feb 13, 2008 3:19 PM, Robin <robince@gmail.com> wrote:
>>> However, even with this done, although scipy.splinalg.dsolve.umfpack
>>> imports, it seems to be missing a lot of attributes, and in fact I
>>> can't find __umfpack.so anywhere. Is it now necessary to use the
>>> scikit, or is there something else wrong with my installation?
>> Please ignore this, setup.py wasn't finding the umfpack library, but
>> it was easy to fix. However I still think the change to linsolve.py is
>> required.
> 
> I've fixed linsolve.py per your suggestion.

1. an apology:
sorry, that was my fault.

2. a little grumble:
is there a reason to require a nose version >= 10? I am not able to run 
the tests for the moment, as I am reluctant to install nose manually and 
my distribution uses nose-0.9.3. IMHO all people should be able to run 
unit tests without requiring a bleeding edge version of some external 
package.

r.



More information about the SciPy-user mailing list