[SciPy-user] scipy install errors

David Cournapeau david@ar.media.kyoto-u.ac...
Wed Feb 20 07:42:34 CST 2008


Alastair Basden wrote:
> Hi David,
> does this apply to the lapack/atlas libraries too?  They're currently 
> compiled with gfortran (I did try g77 but it didn't seem to work), which 
> is what atlas recommends.
>   

Yes, it applies to everything.

> Is it okay to mix versions of gfortran - ie can I use a newer gfortran for 
> scipy, without recompiling the atlas/lapack?
>   

I don't know if it is ok to mix versions of gfortran. Normally, gcc 
doesn't break ABI (binary compatibility) between minor versions, so you 
could try. Note that you should be able to change the fortran compiler 
for ATLAS without recompiling everything (fortran is only used for the 
fortran interface, ATLAS itself is pure C).

David


More information about the SciPy-user mailing list