[SciPy-user] scipy build fails on OS X 10.5

Karl Landsteiner Karl.Landsteiner@gmx...
Sat Jan 5 05:31:58 CST 2008


Hi, 

I am trying to build and install scipy on my new MacBook running
OS X 10.5 Leopard. 
Numpy 1.0.4 build and install worked without problem but 
scipy 0.6.0 build fails.

here are my gcc and gfortran version numbers:

gcc --version
i686-apple-darwin9-gcc-4.0.1 (GCC) 4.0.1 (Apple Inc. build 5465)

gfortran --version
GNU Fortran (GCC) 4.2.1

the relevant errors in the output of "python setup.py build" seem to be

Could not locate executable g77
Could not locate executable f77
Could not locate executable f95
customize GnuFCompiler
customize Gnu95FCompiler
Couldn't match compiler version for 'GNU Fortran (GCC) 4.2.1\nCopyright (C) 2007
 Free Software Foundation, Inc.\n\nGNU Fortran comes with NO WARRANTY, to the ex
tent permitted by law.\nYou may redistribute copies of GNU Fortran\nunder the te
rms of the GNU General Public License.\nFor more information about these matters
, see the file named COPYING\n'
customize G95FCompiler
customize G95FCompiler
customize G95FCompiler using build_clib
running build_ext
customize UnixCCompiler
customize UnixCCompiler using build_ext
customize NAGFCompiler
customize AbsoftFCompiler
customize IbmFCompiler
customize GnuFCompiler
customize Gnu95FCompiler
Couldn't match compiler version for 'GNU Fortran (GCC) 4.2.1\nCopyright (C) 2007
 Free Software Foundation, Inc.\n\nGNU Fortran comes with NO WARRANTY, to the ex
tent permitted by law.\nYou may redistribute copies of GNU Fortran\nunder the te
rms of the GNU General Public License.\nFor more information about these matters
, see the file named COPYING\n'
customize G95FCompiler
...

Thanks for all your help in advance!

-Karl



-- 
GMX FreeMail: 1 GB Postfach, 5 E-Mail-Adressen, 10 Free SMS.
Alle Infos und kostenlose Anmeldung: http://www.gmx.net/de/go/freemail


More information about the SciPy-user mailing list