[SciPy-user] 64 bit build on Mac OS 10.5

Jeff Lyon jeff.lyon@cox....
Mon Jan 7 21:08:03 CST 2008


I was able to build sciPy on a PowerMac G5 running Leopard 10.5.1  
(9B18). I followed the standard installation instructions on the sciPy  
site except that the build failed using gcc 3.3. I switched back to  
gcc 4.0.1 and sciPy built & tested successfully. I'm not sure why this  
happened, but if it ain't broke, don't fix it.

compiler details:

$ gcc -v
Using built-in specs.
Target: powerpc-apple-darwin9
Configured with: /var/tmp/gcc/gcc-5465~16/src/configure --disable- 
checking -enable-werror --prefix=/usr --mandir=/share/man --enable- 
languages=c,objc,c++,obj-c++ --program-transform-name=/^[cg][^.-]*$/s/ 
$/-4.0/ --with-gxx-include-dir=/include/c++/4.0.0 --with-slibdir=/usr/ 
lib --build=i686-apple-darwin9 --program-prefix= --host=powerpc-apple- 
darwin9 --target=powerpc-apple-darwin9
Thread model: posix
gcc version 4.0.1 (Apple Inc. build 5465)


On Jan 7, 2008, at 7:03 PM, Roger Herikstad wrote:

> Hi all,
>  I was wondering if anyone has successfully built scipy with 64 bit  
> support on a Mac Pro running leopard? I would be most grateful if  
> you could share your experience, especially what compiler/linker  
> flags you're using? Thanks!
>
> ~ Roger
> _______________________________________________
> SciPy-user mailing list
> SciPy-user@scipy.org
> http://projects.scipy.org/mailman/listinfo/scipy-user

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://projects.scipy.org/pipermail/scipy-user/attachments/20080107/e0778e78/attachment.html 


More information about the SciPy-user mailing list