[SciPy-user] timeseries import error

Stefan van der Walt stefan@sun.ac...
Fri Jan 18 17:20:49 CST 2008


Hi David

On Fri, Jan 18, 2008 at 12:09:02PM -0500, David Huard wrote:
> The current timeseries depends on scipy.sandbox.maskedarray, but as you have
> seen, it doesnt't work so well. 
> timeseries can be easily modified to depend on the ma module in the numpy
> maskedarray branch, but since the branch dates from about two months, the
> latest changes to numpy haven't  been merged and scipy is currently
> imcompatible with the numpy's maskedarray branch. As a consequence, timeseries
> (depending on scipy.io for instance) won't import.

I have merged the latest numpy changes into the maskedarray branch.
Please try it again, and report any problems.

Thanks
Stéfan


More information about the SciPy-user mailing list